Remember to check out the work-in-progress FAQs: Trine 2 FAQ, Humble Frozenbyte Bundle FAQ. You can also contact us by email.

Shadowgrounds freezes right after start (Ubuntu 13.04 64bit)

Technical support for the Linux & Mac platforms (for Shadowgrounds and Shadowgrounds Survivor).

Shadowgrounds freezes right after start (Ubuntu 13.04 64bit)

Postby zzarko » Wed Jul 24, 2013 3:43 pm (link to this post)

After some trouble to install the game (from humble bundle; I found all the answers on the forums), I managed to start it. But when intro video is shown, and in-game animation starts, right when character touches his right shoulder, the game freezes. I tried many combinations of various video settings (very low also), tried to disable the sound, but nothing helped, it always freezes at that same moment. Graphic card is Radeon HD4750, and I'm using Catalyst drivers (latest for 4000 series).

This is what I used to remove libs:
http://steamcommunity.com/app/2500/disc ... 916177699/

Does anybody have any suggestion as what to try?
zzarko
 
Posts: 1
Joined: Wed Jul 24, 2013 3:07 pm

Postby AnniFB » Tue Jul 30, 2013 2:26 pm (link to this post)

In our tests, the game was working fine until we installed the ATI drivers. After installing them, our game started crashing at the exact same moment as it does for you. Try uninstalling your drivers and see if you get it to work. Or then you could also try if you can get it to work with older drivers. Unfortunately this all means a lot of tweaking just for one older game :/
User avatar
AnniFB
 
Posts: 96
Joined: Tue May 21, 2013 4:45 pm

Postby ilpiero » Sun Dec 29, 2013 1:05 pm (link to this post)

I just bough shadowground and I got the same exact problem, with xubuntu 13.10 64 bits and ati drivers, plus the menu does not save the controls that are all empty... and managing to install the game was a real pain...

I see you guys give good support to the linux community, but if a product has this amount of issues I think you should put a disclaimer or stop selling it.

Thanks.
ilpiero
 
Posts: 1
Joined: Sun Dec 29, 2013 12:53 pm

Postby register » Thu Jan 02, 2014 10:16 pm (link to this post)

I got the same problem
and Shadowgrounds produced no log entry.

Ubuntu 12.04 LTS 64bit
lib32 installed
Catalyst Version 11.8
AMD driver 8.78.3-100920a-105558C-ATI
ATI Radeon HD 4600 Series
OpenGL Version 3.3.11627 Compatibility Profile Context


@ilpiero
For me, saving the controls were only a temporary problem after the first game start.

@AnniFB
Shadowgrounds Installer were missing some libraries but did not produced an error. It was a tricky installation.
register
 
Posts: 1
Joined: Thu Jan 02, 2014 10:04 pm

Postby MarjutFB » Mon Feb 10, 2014 2:46 pm (link to this post)

ilpiero wrote:I just bough shadowground and I got the same exact problem, with xubuntu 13.10 64 bits and ati drivers, plus the menu does not save the controls that are all empty... and managing to install the game was a real pain...

I see you guys give good support to the linux community, but if a product has this amount of issues I think you should put a disclaimer or stop selling it.

Thanks.

register wrote:I got the same problem
and Shadowgrounds produced no log entry.

Ubuntu 12.04 LTS 64bit
lib32 installed
Catalyst Version 11.8
AMD driver 8.78.3-100920a-105558C-ATI
ATI Radeon HD 4600 Series
OpenGL Version 3.3.11627 Compatibility Profile Context


@ilpiero
For me, saving the controls were only a temporary problem after the first game start.

@AnniFB
Shadowgrounds Installer were missing some libraries but did not produced an error. It was a tricky installation.

Hello!

Unfortunately as there is a conflict issue with the game and the drivers - only workaround we can provide is to play with open drivers.

Sorry for the inconvenience.
User avatar
MarjutFB
 
Posts: 70
Joined: Tue Dec 03, 2013 3:48 pm

Postby Draygera2 » Wed Mar 05, 2014 6:59 am (link to this post)

Have you tried building the game from source? Go here and make sure you have git, cmake, boost, and SDL1.2 (sound, ttf and image - I think) installed and follow the instructions in the README.md file. Many of the original Linux release issues seemed to have been solved in the open source version.
Draygera2
 
Posts: 10
Joined: Wed Feb 05, 2014 7:51 am


Return to Technical support for Linux & Mac

Who is online

Users browsing this forum: No registered users and 1 guest